Papamail - Webmail Login Issue Monday 29th April 2024 10:12:00


INVESTIGATING - Apr/29/2024 - 9:00 AM EDT

We are encountering intermittent issues with Cluster A Webmail.

Customers intermittently cannot log in to or access webmail in Cluster A.

We will provide an update once we have additional information.

RESOLVED: Apr/29/2024 - 12:00 PM EDT

The incident involving Hosted Email Cluster A has been resolved. Engineering implemented a fix and service levels have been restored.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.