LiveChat System is experiencing issues Wednesday 1st May 2024 13:15:00


INVESTIGATING: May/01/2024 - 9:15 AM EST

Our LiveChat system is currently experiencing some issues and you may be unable to use it properly now. We're investigating this currently and further updates will be provided here.

You can still reach us by phone or support ticket/email. Thank you for your patience and cooperation.

FIXED: May/01/2024 - 11:00 AM EDT

A fix has been implemented and we are monitoring the results.

We are continuing to monitor for any further issues.

We appreciate your patience and understanding during this outage.

UPDATE: May/01/2024 - 10:30 AM EDT

The issue has been identified and a fix is being implemented.