Papamail - Webmail Login Issue Wednesday 1st May 2024 17:22:34


INVESTIGATING: May/01/2024 - 1:10 PM EDT

We are investigating an issue affecting some users on Cluster A accessing webmail.

IMAP and POP services are unaffected. Our engineering team has been engaged.

We will provide an update once we have additional information.

RESOLVED: May/01/2024 - 2:30 PM EDT

The service has been completely restored. If you are still experiencing issues, please don't hesitate to contact us!

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

Thank you for your patience and understanding!