LiveChat System is experiencing issues Sunday 5th May 2024 16:20:00


INVESTIGATING: May/5/2024 5:20 AM EST

Our LiveChat system is currently experiencing some issues and you may not be able to use it properly at this time. We're investigating this currently and further updates will be provided here.

You can still reach us by phone or support ticket/email. Thank you for your patience and cooperation.

RESOLVED: May/5/2024 - 9:00 AM EST

The issue with our LiveChat has been fixed.

If you encounter any issues on your side, do not hesitate to contact our support via phone or ticket/email.

Thank you for your comprehension and patience during this downtime.

UPDATE: May/05/2024 - 6:00 AM EST

The issue has been identified and a fix is being implemented.

We appreciate your patience.

Further updates to come as they are received.