Basic/Advanced Email Issues Friday 17th July 2020 03:20:00


RESOLVED: 05:05 AM EST

This incident has been resolved. If you continue to experience further issues, please clear your browser cache and try again. If the problem persists, do not hesitate to contact our support team.


UPDATE - IDENTIFIED: 04:05 AM EST

Basic/Advanced email clients are facing degraded service for inbound mail and authentication. The root cause is known and the issues are being investigated to see if a workaround can be put in place to remove the service degradation.

Inbound mail delays range from a few minutes to a couple hours. Generally mail will be queued on the sending mail server and will be received once the connection recovers.

The authentication issue may cause some failures for IMAP/POP/webmail access as well as sending emails. Repeated attempts will likely succeed.


INVESTIGATING: 03:20 AM EST

We are currently investigating issues related to Basic/Advanced email functionality.

At this time this includes bounce back errors on email delivery and timeout errors during logins. We are working to resolve this as quickly as possible and will post further updates here.

Thank you for your patience and cooperation.