HostPapa Dashboard Accessibility Issue Saturday 1st June 2024 01:00:00


HostPapa Dashboard Accessibility: May/31/2024 - 09:00 PM EDT

We have received some reports that the HostPapa Dashboard is having accessibility issues.

We are currently investigating this matter and we apologize for any inconvenience caused.

We will post an update once it's available.

RESOLVED: MAY/31/2024 - 10:07 AM EST

Our HostPapa Dashboard is operating normally again. We are still monitoring to ensure stability.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

UPDATE: May/31/2024 - 10:00 PM EST

Our Engineering Team is working diligently to resolve the HostPapa Dashboard accessibility issue.

We sincerely appreciate your patience and we will post updates as soon as possible.