Basic/Advanced Email Issues Thursday 23rd July 2020 20:05:00


RESOLVED: 09:12 PM EST

This incident has been resolved. If you continue to experience further issues, please clear your browser cache and try again. If the problem persists, do not hesitate to contact our support team.

We deeply apologize for the inconvenience. Thank you for your patience and cooperation.


INVESTIGATING: 08:05 PM EST

We are currently investigating issues related to Basic/Advanced email functionality.

At this time this includes bounce back errors on email delivery and timeout errors during logins. We are working to resolve this as quickly as possible and will post further updates here.

We deeply apologize for the inconvenience. Thank you for your patience and cooperation.