[VPS servers] Multiple Nodes are experiencing issues Wednesday 3rd July 2024 02:45:00


RESOLVED: JUL/03/2024 - 2:40 AM EST

The emergency maintenance has been completed and the VPS servers are back online. We are still monitoring to ensure stability.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact


EMERGENCY MAINTENANCE: Jul/02/2024 - 10:45 PM EST

Some of our VPS servers are experiencing issues at this time.

We sincerely apologize for any inconvenience caused. Rest assured, our Engineering team is already aware and working diligently to fix the issue.

We will post updates once available and we truly appreciate your patience.

UPDATE: JUL/03/2024 - 12:05 AM EST

We are still having emergency maintenance on the affected nodes. Be assured that our Network Engineers are exerting their best efforts to get everything back to normal.

We will post updates once all the services are restored. Thank you for being so patient.