LiveChat System is experiencing issues Thursday 8th August 2024 14:16:23


INVESTIGATING: Aug/08/2024 - 2:05 PM EDT

Our LiveChat system is currently experiencing some issues and you may be unable to use it properly now. We're investigating this currently and further updates will be provided here.

You can still reach us by phone or via a support ticket/email. Thank you for your patience and cooperation.

RESOLVED: Aug/08/2024 - 5:00 PM EDT

A fix has been implemented and we are monitoring the results.

We apologize for any inconvenience caused by this issue.

UPDATE: Aug/08/2024 - 4:35 PM EDT

We are continuing to work on a fix for this issue.