S119 - Emergency maintenance Friday 23rd August 2024 03:00:00


COMPLETED: AUG/23/2024 - 08:40 AM EST

The emergency maintenance has been completed and the server S119 is operating normally again after closely monitoring it.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.


Update: AUG/23/2024 - 06:00 AM EST

We have encountered some performance issues with server S119 , we are focusing on creating a permanent fix. More updates will follow

We sincerely apologize for any inconvenience caused.


EMERGENCY MAINTENANCE: AUG/23/2024 - 03:00 AM EST

Server S119 is having maintenance performed on it, and as such services located on this server may be affected and become inaccessible.

We sincerely apologize for any inconvenience caused.