S119 - Emergency Maintenance Saturday 24th August 2024 13:19:00


EMERGENCY MAINTENANCE: AUG/24/2024 - 1:20 PM EST

Server S119 is undergoing maintenance, and as such, its services may be affected and become inaccessible.

Our server health team is monitoring the server to ensure stability.

We sincerely apologize for any inconvenience caused.

COMPLETED: AUG/25/2024 - 07:57 PM EST

The emergency maintenance has been completed and the server S119 is operating normally again after closely monitoring it.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

UPDATE: AUG/24/2024 - 10:21 PM EST

S119 is still having emergency maintenance. Rest assured, our Network Engineers are doing their best to get everything back to normal.

We will post updates once all the services are restored. Thank you for being so patient.