HP301 Emergency Maintenance Thursday 13th August 2020 03:30:00


RESOLVED: 04:30 AM EST

The server is back online and under normal load at this time. All sites should be working normally.

If you continue to have issues please contact our support team to further troubleshoot.


INVESTIGATING: 03:30 AM EST

Server HP301 is currently undergoing emergency maintenance and will be back online as soon as possible.

Clients with services on this server may notice latency in requests or site not loading errors intermittently. We will provide further updates via this status page as they are made available.

Our server health team is working on the issue directly at this time and we thank you for your patience and understanding while its being resolved.