Papamail/cPanel Webmail Accessibility Issue Thursday 5th September 2024 18:45:00


INVESTIGATING: SEP/05/2024 - 06:45 PM EDT

We are currently investigating the reports about webmail access problems.

Rest assured that we are actively investigating the issue and will provide an update as soon as more information becomes available.

RESOLVED: SEP/05/2024 - 09:45 PM EDT

We have closely monitored this incident and we are glad to announce that the webmail accessibility problems using Optus have been fixed.

Should you continue having issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.

UPDATE: SEP/05/2024 - 07:35 PM EDT

Upon investigation, it appears that the server has been completely operational. All reports suggest that the webmail accessibility issues are happening to the Optus network provider. Therefore, we kindly ask your cooperation to contact your ISP for further information.

Rest assured that we are still closely monitoring the situation. If you have further concerns, please reach out to us anytime. Thank you.