Multiple VPS & Korax VSD's - Emergency maintenance Friday 6th September 2024 22:19:00


UPDATE: SEP/07/2024 - 04:40 AM EST

All VPS servers are now working and operational.

==================================================================

UPDATE:

Only a small number of servers are still affected and we are still working to bring everything back online

================================================================

EMERGENCY MAINTENANCE: SEP/06/2024 - 10:11 PM EST

We are currently experiencing network connection issues affecting multiple Virtual Private Servers (VPSs) and Korax Servers. Our Server Health team is actively collaborating with our data center to resolve this issue as swiftly as possible.

We apologize for any inconvenience this may cause and will provide further updates here as they become available. Thank you for your patience.