s133 connectivity issues Saturday 15th August 2020 08:10:00


Update 10:25am EST: The server is now running as expected. Thank you for your patience!


INVESTIGATING 08:00 AM EST

Our server health team is currently investigating reported connectivity issues with the s133 server. Updates will be posted as soon as they come in.

We sincerely apologize for the inconvenience caused.