HP Dashboard Credential Issues Tuesday 22nd October 2024 11:48:42


Investigating: October 22, 2024 - 11:45 AM EST

Issue: We have received reports from some customers experiencing issues with the HP Dashboard where their credentials are failing, even though they are correct.

Impact: Affected customers may be unable to log in to the HP Dashboard.

Current Status: Our team is actively investigating the issue and working to find a fix as quickly as possible. We apologize for any inconvenience this may cause and appreciate your patience.

Next Update: We will provide an update as soon as we have more information or within the next hour.

Contact: If you have any questions or need further assistance, please contact our support team via chat, phone, or email/ticket.

Resolved: October 22. 2024 - 12:30 PM EST

Resolution: Our team has identified and fixed the issue. Affected customers should now be able to log in to the HP Dashboard without any problems.

Impact: The issue has been resolved, and the HP Dashboard is functioning normally.

Contact: If you continue to experience any issues or have any questions, please contact our support team at hostpapa.com/about-hostpapa/contact/