Papamail - Webmail Login Issue Tuesday 5th November 2024 10:16:00


INVESTIGATING - NOV/05/2024 - 10:15 AM EST

We are currently experiencing intermittent issues with Papamail (Basic and Advanced). As a result, some customers may encounter difficulties logging in or accessing webmail at mail.papamail.net.

We are actively investigating the issue and will provide an update as soon as more information becomes available.

RESOLVED: NOV/05/2024

After monitoring for a few hours, we can confirm that this incident has been resolved. Cluster A Webmail/IMAP/POP services restored.

We appreciate your understanding and patience during this outage. If you still have any issues, do not hesitate to contact our live support.

IDENTIFIED: NOV/05/2024 - 2:15 PM EST

The issue has been identified and a fix is being implemented. Further updates will be provided.

UPDATE: NOV/05/2024 - 1:30 PM EST

This issue impacts IMAP/POP connections as well.

Our team is currently still investigating the issue and working on a fix. We thank you for your continued patience with this case.

UPDATE: NOV/05/2024 - 12:00 PM EST

Our team is still looking into the cause, and we'll continue to update you on our progress.