Scheduled Maintenante - Multiple Windows VPS Wednesday 6th November 2024 12:00:00


Scheduled Maintenance: Nov/06/2024 - 12:00 PM - 6:00PM EST

We have a scheduled Maintenance that will be affecting multiple Windows Virtual Private Servers (VPSs) . Our Server Health team will be actively collaborating with our data center to finish this maintenance as swiftly as possible.

We apologize for any inconvenience this may cause and will provide further updates here as they become available. Thank you for your patience.

COMPLETED: NOV/06/2024 - 4:00 PM EST

The maintenance was completed and our Windows VPSs are working fine.

If you notice any issues, do not hesitate to contact us as soon as possible.

Thank you for your comprehension during this time.

UPDATE: NOV/06/2024 - 2:40 PM EST

The maintenance is still ongoing. We'll be updating this thread as soon as this task is completed.

We apologize for any inconvenience and appreciate your patience and understanding.