Papamail - Webmail Login Issue Wednesday 6th November 2024 07:00:00


INVESTIGATING - NOV/06/2024 - 07:00 AM EST

We are currently experiencing intermittent issues with Papamail (Basic and Advanced). As a result, some customers may encounter difficulties logging in or accessing webmail at mail.papamail.net.

We are actively investigating the issue and will provide an update as soon as more information becomes available.

RESOLVED: NOV/06/2024 - 5:30 PM EST

After closely monitoring the case for the past few hours, we're pleased to inform you that the incident has been resolved.

We appreciate your patience and cooperation throughout this process. Thank you for your understanding.

RESOLVED: NOV/05/2024 - 5:30 PM EST

After closely monitoring the case for the past few hours, we're pleased to inform you that the incident has been resolved.

We appreciate your patience and cooperation throughout this process. Thank you for your understanding.

UPDATE - NOV/06/2024 - 11:15 AM EST

Some of our customers are still experiencing login and/or connectivity issues.

We are actively working on a permanent fix for these issues.

UPDATE - NOV/06/2024 - 7:30 AM EST

All services appear to be up and running for Cluster A We will continue to monitor for a short period before closing.

Thank you for your patience.