Papamail - Webmail Login Issues Monday 11th November 2024 15:50:59


INVESTIGATING - NOV/11/2024 - 3:50 PM EST

We are investigating an issue preventing some users on Cluster A from accessing their accounts. Our engineering team has been engaged.

We will provide an update once we have additional information.

RESOLVED: NOV/11/2024 - 7:00 PM EST

This incident has been resolved.

We apologize for any inconvenience caused.

If you still notice any issues, do not hesitate to reach out to our support.

Thanks for your patience.

UPDATE - NOV/11/2024 - 5:10 PM EST

Our engineers continue to investigate this matter impacting a small subset of users.