Papamail - Webmail Login Issues Wednesday 13th November 2024 22:40:00


INVESTIGATING - NOV/13/2024 - 10:40 PM EST

We are currently investigating an issue in Cluster A involving email accessibility issues.

Rest assured, our Engineering team is working diligently to complete the maintenance work to fix the issues.

We will keep you posted and please accept our sincerest apologies for the inconvenience.

RESOLVED: NOV/14/2024 - 5:55 AM EST

This incident has been resolved.

We apologize for any inconvenience caused.

If you still notice any issues, do not hesitate to reach out to our support.

Thanks for your patience.

.

UPDATE: NOV/14/2024 - 12:50 AM EST

The maintenance is still being completed. Rest assured that our Engineering team is working tirelessly to resolve this incident.

We'll post another update as soon as the maintenance is complete. Thank you for all your patience.