Papamail - Webmail Login Issues Thursday 14th November 2024 11:59:05


INVESTIGATING: NOV/14/2024 - 10:35 AM EST

We're aware that some users are experiencing intermittent issues with accessing webmail, as well as sending and receiving emails.

Our dedicated teams are actively investigating the situation to resolve it as quickly as possible.

We appreciate your patience and understanding.

RESOLVED: NOV/14/2024 - 2:10 PM EST

We're glad to inform you that this incident has been resolved. Services are fully recovered.

We appreciate your patience and understanding during this time.

If you notice any issues on your side, do not hesitate to contact our support.

NOV/14/2024 - 1:50 PM EST - We are continuing to monitor the results. Services remain stable.

NOV/14/2024 - 12:35 PM EST

A fix has been implemented and we are monitoring the results.

UPDATE: NOV/14/2024 - 11:10 AM EST

Some users may still experience intermittent issues accessing Webmail on Cluster A. This could affect logging in and may cause occasional sluggish responses while using the service.

We are actively working on resolving this and will keep you updated. Thank you for your patience and understanding.