Papamail - Webmail Login Issues Thursday 14th November 2024 18:27:00


INVESTIGATING: NOV/14/2024 - 6:10 PM EST

We are aware of an increasing number of reports regarding webmail login and loading failures.

Our engineering team is actively investigating the issue.

Further updates will be provided as they become available.

RESOLVED: NOV/15/2024 - 12:00 AM EST

We are glad to announce that the maintenance was completed and the email services should be operational.

Once again, we sincerely appreciate all your patience during the maintenance period.

Should you continue having issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

UPDATE: NOV/14/2024 - 09:47 PM EST

The maintenance work is currently performed in the Papamail servers due to the increasing number of reports from users experiencing webmail login/loading failures. Once again, our Engineering Team is aware and will diligently work on resolving the issues.

Rest assured, we will provide more updates as they become available. We sincerely appreciate all your patience.