Papamail - Webmail Login Issues Monday 18th November 2024 07:49:55


INVESTIGATING: NOV/18/2024 - 7:48 AM EST

We are aware of an increasing number of reports regarding webmail login and loading failures.

Our engineering team is actively investigating the issue.

Further updates will be provided as they become available.

RESOLVED: NOV/18/2024 - 3:00 PM EST

The issue affecting a small group of email accounts has been resolved.

Email services, including POP/IMAP and webmail, are now functioning as expected.

We apologize for any inconvenience this may have caused and are here to assist with any further issues or concerns.

Thank you for your patience and understanding.

NOV/18/2024 - 12:26 PM EST

We are currently investigating reports of some customers having connectivity issues affecting account access.

We will investigate this and follow up with updates.

NOV/18/2024 - 11:15 AM EST

Mail services have remained the same for the last hour, but are still intermittently slower than our target response times.

We are continuing to work on this and monitor the results and will post updates as they are available.

NOV/18/2024 - 10:25 AM EST

The Pop/IMAP connections are currently returning to expected levels for both mail clients and webmail access.

We are monitoring this and will provide updates.

NOV/18/2024 - 10:00 AM EST

This issue is confirmed to be affecting Cluster A mail client connections as well, with intermittent issues syncing mail clients for sending and receiving.

We are continuing to look into this, and thank you for your patience.