Papamail - Webmail Login Issues Thursday 21st November 2024 11:20:00


INVESTIGATING: NOV/21/2024 - 11:10 AM EST

We are aware of an issue preventing some users on Cluster A from logging into Webmail. HostedEmail is experiencing delays that are affecting webmail access. IMAP and POP services are also affected.

Our dedicated engineering team is actively investigating and working to resolve the problem quickly.

We understand how important this service is to you, and we appreciate your patience. We will provide updates as soon as we have more information.

RESOLVED: NOV/21/2024 - 12:30 PM EST

This issue has been resolved.

We appreciate your patience and understanding during this time.

If you encounter any issues with your Papamail account, do not hesitate to contact us. Thank you!

MONITORING: NOV/21/2024 - 11:50 AM EST

A fix has been implemented and we are monitoring the results.