Papamail - Emergency maintenance Tuesday 26th November 2024 09:25:00


INVESTIGATING: NOV/26/2024 - 09:25 AM EST

We are currently investigating an ongoing issue with Papamail. IMAP, POP, and Webmail access on PapaMail services will be affected.

Our dedicated engineering team is actively investigating and working to resolve the problem quickly.

We understand how important this service is to you, and we appreciate your patience. We will provide updates as soon as we have more information.

RESOLVED: NOV/27/2024 - 9:17 AM EST

We are pleased to inform you that the service is now functioning as expected.

We sincerely apologize for the disruption.

Thank you once again for your patience.

IDENTIFIED: NOV/26/2024 - 6:00 PM EST

While engineers have brought systems up to stability, further troubleshooting and investigation are ongoing.

UPDATE: NOV/26/2024 - 3:20 PM EST

The HostedEmail issue affecting Cluster A mailboxes is still being worked on by the engineering team. We will continue to provide updates as they become available.

UPDATE: NOV/26/2024 - 12:30 PM EST

The engineering team is continuing to address the HostedEmail issues. Further updates will be provided as they become available.

Thank you for your patience as we work to resolve this.

UPDATE: NOV/26/2024 - 10:40 AM EST

We are continuing to investigate this issue. Engineering is working on identifying the cause and attempting a fix.