RESOLVED: Dec/01/2024 - 4:15 PM EST
We are pleased to inform you that the service is now functioning as expected.
We sincerely apologize for the disruption.
Thank you once again for your patience.
INVESTIGATING: Dec/01/2024 - 10:15 AM EST
We are currently investigating an ongoing issue with Papamail. IMAP, POP, and Webmail access on PapaMail services will be affected.
Our dedicated engineering team is actively investigating and working to resolve the problem quickly.
We understand how important this service is to you, and we appreciate your patience. We will provide updates as soon as we have more information.