Potential issue affecting Microsoft Office 365 Monday 28th September 2020 19:00:00


RESOLVED 09/29/2020 01:00 AM EST

After the extended monitoring of Microsoft's service, they have confirmed that the issue has been fully mitigated and is running within optimal service levels.

If you are still experiencing issues from your end relating to your Microsoft Office 365 service, please contact us through email, chat, or phone so our support representatives can further assist with any additional concerns.

We apologize for the inconvenience that this caused you and we also appreciate your patience in this matter.


MONITORING 09/29/2020 12:00 AM EST

Microsoft engineers have confirmed that their monitoring indicates that service health has been restored for all regions. They are continuing to monitor to ensure the issue is fully resolved.

We will provide updates as they made available.


UPDATE 09:00 PM EST

Microsoft's mitigation strategy was successful in allowing users to sign into the previously impacted services. Their internal monitoring has validated this recovery and they have received positive confirmation from customer reports.

We will provide updates as they made available.


UPDATE 08:00 PM EST

Microsoft has determined that a specific portion of their infrastructure is not processing authentication requests in a timely manner. They are pursuing mitigation steps for this issue. In parallel, they're also rerouting traffic to alternate systems to provide further relief to the affected users.

Sorry for the inconvenience. We will provide updates as they made available.


Microsoft is investigating a potential issue affecting Outlook.com.

Affected users may be unable to access Outlook.com services or features such as webmail portals, etc. Existing sessions do not appear to be affected. Affected users are encouraged to keep existing sessions going and to avoid re-authenticating to Outlook.com services.

Microsoft engineers are already working on a fix. Sorry for the inconvenience that this has caused you.

We will provide updates as they made available.