Papamail Password Issue Thursday 30th January 2025 14:57:20


INVESTIGATING: JAN/30/2025 - 2:30 PM EST

Incident Details: We are currently aware of an issue where customers are being prompted to re-enter their password when trying to send an email through Papamail. Our team is working diligently to resolve this as soon as possible.

Next Steps: Our engineers are investigating the root cause and working on a fix. We appreciate your patience and will provide updates as soon as we have more information.

We apologize for this inconvenience and appreciate your patience and understanding.

RESOLVED: JAN/30/2025 - 4:00 PM EST

The fix has been successful. This incident has been resolved.

We appreciate your understanding during this downtime and are at your disposal if you encounter any issues with the service.