HostPapa Dashboard and Ticketing Accessibility Issue Thursday 6th February 2025 00:00:00


EMERGENCY MAINTENANCE: FEB/06/2025 - 12:00 AM EST

We are currently having emergency maintenance on the ticketing and dashboard systems.

The downtime expected during this time will approximately take around 10-20 minutes.

Please accept our sincere apologies for the inconvenience that this has caused. Rest assured, we'll post further updates once our system is fully operational.

Your patience and understanding are sincerely appreciated. Thank you.

UPDATE: FEB/06/2025 - 1:00 AM EST

To achieve optimal system performance, our System Engineers are finalizing the database restore after maintenance.

As a result, latency issues may be encountered in your HostPapa Dashboard and ticketing system.

We'll keep you updated as soon as possible. Once again, thank you for your consideration.

COMPLETED: FEB/06/2025 - 02:00 AM EST

The emergency maintenance on the ticketing and dashboard systems was completed and the system is functioning normally.

If you continue to experience any issues or have any questions, please contact our support team at hostpapa.com/about-hostpapa/contact/