Multiple servers - Networking issue Monday 7th April 2025 22:00:00


Investigating: April/3/2025 - 10:20 PM EST

We are currently experiencing an issue with the multiple servers.

Our team is actively investigating to identify the root cause and will provide updates as soon as more information is available.

We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve the issue.

RESOLVED: APR/4/2025 - 01:20 AM EST

We are glad to announce that the networking issue on multiple servers were resolved and the services should be operational.

Should you continue having issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

UPDATE: April/3/2025 - 10:36 PM EST

Based on the investigation, we discovered that the root cause is an upstream provider.

Rest assured, our System Engineers are exerting their best efforts to restore the services as soon as possible.

We'll keep you updated as soon as possible. Once again, we sincerely appreciate your patience and understanding.