Network Connectivity Issues - Multiple Servers Friday 23rd May 2025 00:34:00


Investigating: MAY/23/2025 12:34 AM

Our technicians are currently investigating networking issues on multiple servers. We are working to identify the root cause and will provide updates as soon as more information is available.

We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve the issue.

UPDATE: MAY/23/2025 01:26 AM EST

Based on our recent findings, we determined that the servers are fully operational.

Regretfully, we established that affected servers are caused by the customer's Internet Service Provider (ISP) routing traffic through Cogent, which is outside the direct control of HostPapa.

We have contacted Cogent and confirmed that the outage is due to a fiber cut in Salt Lake City.

At this time, Congent has no estimated time of arrival (ETA) for resolution.

We are closely monitoring the situation to ensure the issue is fully resolved.