Multiple servers - Networking issue Wednesday 9th July 2025 10:00:00


INVESTIGATING: JULY/09/2025 - 10:00 AM EST

We are currently experiencing an issue with the multiple servers.

Our team is actively investigating to identify the root cause and will provide updates as soon as more information is available.

We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve the issue.


RESOLVED: JULY/09/2025 - 10:30 AM EST

We are glad to announce that the networking issue on multiple servers were resolved and the services should be operational.

Should you continue having issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.