EMERGENCY MAINTENANCE - R201 Friday 3rd October 2025 16:44:00


EMERGENCY MAINTENANCE: OCT/03/2025 - 4:40 PM EST

Server r201 is undergoing maintenance, so its services may be affected and become inaccessible.

Further updates will be posted here. Thank you

UPDATE: OCT/04/2025 - 12:10 AM EST

We have performed emergency maintenance on server R201, however, our Server Health team is actively investigating incident reports involving the server, specifically concerning network delays.

Our team is working diligently to resolve this issue, and we will provide updates as soon as they become available.


COMPLETED: OCT/05/2025 - 10:00 AM EST

The server maintenance has been completed, but we are still monitoring it to ensure its stability. For further assistance related to this, kindly reach out to us via our live chat or phone support.