HP295 server offline Monday 14th December 2020 21:00:00


RESOLVED 09:54 PM EST

The server health team has restored the services to HP295 and it is functioning normally at this time.

If you continue to experience any issues, please contact our support team.


HP295 is experiencing issues at this time and remains offline. Websites and email accounts hosted here will experience connectivity issues at this time.

Our server health team is aware and working on the issue to have it resolved as quickly as possible.

Updates on the issue will be posted here. Sorry for the inconvenience that this has caused you. Thank you for your patience and cooperation.