Performance issues - res-cp3-us.yyz2 Saturday 13th December 2025 19:29:42


INVESTIGATING: Dec/13/2025 07:28 PM EST

We are experiencing some performance issues that may affect the ability of clients to access websites on the server res-cp3-us.yyz2.

This is being investigated by our Server Health team, and they are working to resolve the issue as soon as possible.

We sincerely apologize for the inconvenience that this has caused.

We will post further updates on this page until the issue is resolved.

RESOLVED: DEC/13/2025 - 08:43 PM EST

We are pleased to announce that the server performance issue has been resolved, and the services should now be operational.

Should you continue having issues, don't hesitate to get in touch with our support team via LiveChat, Phone, or Email/Support Ticket

We appreciate your patience. Have a good day!