Live Support System Maintenance Wednesday 8th April 2026 12:54:51
INVESTIGATING: Apr/08/2026 12:50 PM
We are currently experiencing slowness and intermittent responsiveness across our support platform.
This is being investigated, and we will update this status page periodically until resolved.
Thank you
RESOLVED: Apr/08/2026 1:30 PM
The performance issues affecting our Live Support System have been resolved. The platform is now fully operational, and normal responsiveness has been restored.
We apologize for any inconvenience this may have caused and thank you for your patience.