Maintenance – cPanel Access & Logins Tuesday 28th April 2026 16:31:45


We are currently performing maintenance related to cPanel and WHM login access following a recently identified security concern.

This action is being taken to ensure the continued safety and integrity of all hosting environments.

During this period, you may experience:

Our team is actively working to apply necessary updates and mitigate any potential risks.

For more details on the issue, please refer to the official advisory: https://support.cpanel.net/hc/en-us/articles/40073787579671-Critical-Vulnerability-with-cPanel-WHM-Login-Authentication

We appreciate your patience and understanding while we complete this maintenance.

Further updates will be shared as progress is made.

UPDATE: APR/28/2026 - 11:49 PM EST

Shared and Reseller hosting maintenance is now complete, resolving the recent cPanel/WHM security concerns. Full access to these services has been restored.

Updates for VPS services are still underway. We will provide further information as it becomes available.

Should you continue having issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

Once again, we sincerely appreciate your patience while we complete this maintenance.