Papamail - Advanced/Basic SMTP Error Wednesday 1st July 2026 20:55:00


INVESTIGATING: Jul/1/2026 08:58 PM EST

We are investigating an SMTP issue affecting Advanced/Basic email users. Our Engineering team is already working on a resolution as soon as possible.

We sincerely apologize for the inconvenience caused. We will provide an update once we have additional information.

RESOLVED: JUL/01/2026 - 10:00 PM EST

Our engineering team identified the root cause and successfully implemented a permanent fix. All email services are now functioning normally. We are actively monitoring our systems to ensure continued stability. Thank you for your patience and understanding while we worked to resolve this issue.

Should you continue having issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.