Delayed Provisioning of New and Migrated Accounts Wednesday 20th January 2021 05:30:00


RESOLVED: 20/01/2021 01:30 PM EST

The root cause of the issue has been found and all servers affected have been fixed. There will be no further delays regarding provisioning of new accounts.

Should you continue to experience delays in any new account setup, please contact our support team.


INVESTIGATING: 20/01/2021 05:30 AM EST

At this time you may experience a delay in the provisioning (setup) of a new account. The issue is also affecting new accounts being setup for migrations.

Our server technicians are aware of the issue and working on a resolution at this time. Further updates will be posted here.

Thank you for your patience and cooperation.