SpamExperts Issues Affecting Email Delivery Sunday 31st January 2021 10:07:00


FIXED: 01/02/2021 06:50 AM EST

A fix has been applied to all servers at this time.

There may be some delay due to propagation of the new settings. Should you continue to experience issues, please test your email directly from webmail first. If it also does not work there, please reach out to our support team.

Thank you for your patience and cooperation.


UPDATE: 01/02/2021 02:45 AM EST

Most servers have had a fix applied to resolve the email delivery issue. A handful of servers have not been able to have the fix applied and we're working to update them as quickly as possible.

You may still be experiencing email delivery issues if you're email is hosted on one of the following servers. S114, S120. S131, S133, HP225

Further updates will continue to be published here. Thank you for your patience and cooperation.


UPDATE:

It seems we are still experiencing issues on this matter and we are actively working on solving them. We apologize for the inconveniences caused and we will provide further updates soon.


Resolved

The issues have been corrected by our system administrators. We thank you for your patience and understanding while dealing with this. If you still experience any issues please reach out to us via Livechat or tickets and we will help


We are experiencing some issues with email delivery due to SpamExperts. Our system administrators are working on a fix and further updates will be posted here. Please reach out to our support team via Live Chat, should you require further assistance. We sincerely apologize for the inconvenience caused.