Emails bouncing with 550 Error (Spam Filter) Thursday 24th June 2021 06:00:00


COMPLETE: 25/03/2021 04:30 PM EST

The issue has been resolved and the servers are operating normally again at this time.

Should you continue to have any issues, please contact our support team via LiveChat, Phone or Email/Support Ticket. You can find all our contact info at www.hostpapa.com .


UPDATE: 24/06/2021 03:45 PM EST

Our team has performed emergency maintenance to fix this issue. Email delivery should be back to normal now, however, we are still monitoring it to review some isolated cases.

We appreciate your patience and cooperation, and we apologize for the inconvenience caused.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com.


UPDATE: 24/06/2021 01:30 PM EST

We are still working to fix this issue. We appreciate your patience and cooperation while this is being resolved.

Further updates will be posted here.


UPDATE: 24/06/2021 09:15 AM EST

Our server technicians continue to investigate the issue. We appreciate your patience while this is being resolved.

Further updates will be posted here.


INVESTIGATING: 24/06/2021 06:00 AM EST

Emails are bouncing for some clients with a 550 spam filter bounce back message. This is currently being investigated and further updates will be posted here.

We're sorry for the inconvenience regarding email delivery at this time, we're working to resolve it ASAP. Thank you for your patience and cooperation.