LFC Server Down (Server 41) - Hardware Issues Sunday 27th June 2021 11:00:00


COMPLETE: 29/06/2021 11:30 AM EST

The restoration is completed and LFC server 41 is operating normally again at this time.

Should you continue to have any issues, please contact our support team.

Thank you for your cooperation and understanding.


UPDATE: 03:22 PM EST

The services are already back online while the restoration of the data is still ongoing. Until the restoration is complete, some sites hosted on this server may not load properly or appear outdated. Further updates will be provided once made available.

We sincerely apologize for the inconvenience and thank you for your patience.


UPDATE: 28/06/2021 09:30 AM EST

The server is back online with some services back online also. The outage affected data on the server. Restoration of the data continues at this time to resolve loading issues as quickly as possible. Until restoration is complete, sites hosted on this server may not load correctly.

We greatly appreciate your continued patience. Further updates will be posted here.


UPDATE: 28/06/2021 04:20 AM EST

Some sites and their data are coming back online while the issue continues to be resolved.

Further updates will be posted here, we appreciate your patience.


EMERGENCY OUTAGE: 27/06/2021 11:00 AM EST

Due to a hardware failure on LFC Server 41, LFC clients hosted on this server will be experiencing issues loading their services/sites. This is being worked on by our server support team and further updates will be posted here.

Thank you for your patience and cooperation in regards to resolving this issue.