Intermittent Connectivity Issues (multiple servers) Friday 9th July 2021 13:40:00


FIXED 03:20 PM EST

Our Server Admins have fixed the issue. If you are still experiencing issues with your website, emails, etc., please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


INVESTIGATING 1:40 PM EST

Some servers are expecting latency, and some customers may experience intermittent connectivity issues. Our Server Health team is already aware and investigating the issue.

Further updates will be posted here.

Thank you for your patience and cooperation regarding troubleshooting this issue.