VPS connectivity issues Monday 6th September 2021 02:34:00


FIXED: Sep/15/2021 04:50 AM EST

Our Server Admins have fixed the issue and VPS accounts should now be accessible. If you are still experiencing issues with your account access, website, emails, etc., please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


UPDATE: Sep/14/2021 8:30 PM EST

The restoration of the services performed by our System Admins is still ongoing. We sincerely apologize for the inconvenience that this has caused.

Thank you for your continued patience and understanding while the issue is being resolved. We will post further updates once available.


UPDATE: Sep/10/2021 10:30 AM EST

The restoration of the services is still ongoing at this time. We sincerely apologize for the inconvenience that this has caused.

Thank you for your continued patience and understanding while the issue is being resolved. We will post further updates once available.


UPDATE: Sep/10/2021 12:30 AM EST

The restoration of the services is still ongoing at this time. We sincerely apologize for the inconvenience that this has caused.

Thank you for your continued patience and understanding while the issue is being resolved. We will post further updates once available.


UPDATE: Sep/9/2021 09:30 AM EST

The restoration of the services performed by our System Admins is still ongoing. We sincerely apologize for the inconvenience that this has caused.

Thank you for your continued patience and understanding while the issue is being resolved. We will post further updates once available.


UPDATE: Sep/8/2021 12:30 AM EST

The restoration of the services performed by our System Admins is still ongoing. We sincerely apologize for the inconvenience that this has caused.

Thank you for your continued patience and understanding while the issue is being resolved. We will post further updates once available.


UPDATE: Sep/8/2021 12:00 AM EST

Our Server Admins are continuously working on the restoration of the services as soon as possible. We sincerely apologize for the inconvenience that this has caused.

Thank you for your continued patience and understanding while the issue is being resolved. We will post further updates once available.


UPDATE: Sep/7/2021 08:45 AM EST

Our Server Admins are still working continuously on the restoration of the services as soon as possible.

Thank you for your continued patience and understanding while the issue is being resolved. We are very sorry for the inconvenience that this has caused you. We will post further updates once available.


UPDATE: Sep/7/2021 01:00 AM EST

Our Server Admins are still working continuously on the restoration of the services as soon as possible.

Thank you for your continuous patience and understanding while the issue is being resolved. We are very sorry for the inconvenience that this has caused you. We will post further updates once available.


UPDATE: Sep/06/2021 07:00 PM EST

Our Server Admins are currently working to fix the issue as soon as possible.

Thank you for your patience and understanding while it's being resolved. We sincerely apologize for any inconvenience caused. We will post further updates once available.


UPDATE: Sep/06/2021 01:30 PM EST

Our Server Admins identified the cause of the issue, and they are working to fix it as soon as possible.

We sincerely apologize for any inconvenience caused. We will post updates as they made available.


INVESTIGATING: Sep/06/2021 02:24 AM EST

Our server health team is currently investigating connectivity issues related to websites hosted in VPS servers. Clients may notice latency in requests or site not loading errors. We will provide further updates via this status page as they are made available.

Thank you for your patience and understanding while it's being resolved. We sincerely apologize for the inconvenience caused.