Korax Mail Server - issues Thursday 16th September 2021 16:00:00


INVESTIGATING: 17/09/2021 1:00 PM EST

Korax mail server is still experiencing issues accessing or disconnections from the webmail and mail clients. Our Server Administrators are still investigating into this issue and working to resolve it as quickly as possible.

Further updates will be posted here as available.


INVESTIGATING: 16/09/2021 4:00 PM EST

The Korax mail server is currently experiencing issues with SMTP services which may result in disconnection and inability to login via email client (Outlook, Macmail, etc.) as well as webmail. Our Server Administrators are investigating into this issue and working to resolve it as quickly as possible.

Further updates will be posted here as available.