Basic/Advanced Email Issue Friday 17th September 2021 11:40:00


FIXED Sep/17/2021 02:30 PM EST

Our engineering team has fixed the issue. If you are still experiencing issues with your emails, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


INVESTIGATING: Sep/17/2021 11:40 AM EST

We are currently experiencing login issues with HostPapa Basic/Advanced email accounts.

We are investigating this at this time, and will provide updates as they are available.

Thank you for your patience.