VPS connectivity issues Wednesday 13th October 2021 13:55:00


FIXED: Oct/13/2021 02:30 PM EST

Our Server Admins have fixed the issue and VPS accounts should now be accessible. If you are still experiencing issues with your account access, website, emails, etc., please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


INVESTIGATING: Oct/13/2021 01:55 PM EST

Our server health team is currently investigating connectivity issues related to websites hosted in VPS servers. Clients may notice latency in requests or site not loading errors. We will provide further updates via this status page as they are made available.

Thank you for your patience and understanding while it's being resolved. We sincerely apologize for the inconvenience caused.