Performance Issues - multiple servers Friday 22nd October 2021 14:35:00


FIXED: Oct/22/2021 4:00 PM EST

Our Server Admins have fixed the issue. If you are still experiencing issues with your website, emails, etc., please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


INVESTIGATING: Oct/22/2021 02:35 PM EST

We are experiencing instability in different servers. Websites and emails can be affected. This is being investigated in order to be corrected.

Further updates will be posted here.

We appreciate your patience while the issue is being resolved.