R132 - Performance Issues Monday 25th October 2021 14:00:00


FIXED: Oct/26/2021 10:00 AM EST

Our Server Admins have fixed the issue. If you are still experiencing issues with your website, please contact our Support team through Live Chat, Phone, or Email [email protected]

Thank you for your patience in this matter.


INVESTIGATING: Oct/25/2021 02:00 PM EST

R132 is currently experiencing high load issues. Some sites might show errors when loading.

Our Server Health team is aware of the issue and working to fix it as soon as possible. We apologize for the inconvenience caused.

Further updates will be posted here. Thank you for your patience.